artifact_id;status_id;status_name;priority;submitter_id;submitter_name;assigned_to_id;assigned_to_name;open_date;close_date;last_modified_date;summary;details;"Host";"Forwarded Upstream" 28;1;"Open";3;102;"Sylvain Le Gall";103;"Stefano Zacchiroli";"2008-05-15 14:06";"";"2011-12-14 17:37";"dar is good lets use it on a longer period";"After having try dar for some restore, i think dar is a good tool. Maybe we could store data for a longer period with it (e.g. 1 month). Anyway, thanks for making me discover it.";"None";"None" 225;1;"Open";3;255;"Mike Furr";107;"Romain Beauxis";"2009-06-18 15:41";"";"2009-09-28 22:17";"initial mailing list setup email is in French";" After creating a new project (ohudson) which uses svn, I received an email written in french that a -commits mailing list had been automatically setup. My language preference is set to English and all other emails from the site have matched that, so perhaps this email is missing a translation? ";"None";"None" 501;1;"Open";3;233;"Julien Signoles";102;"Sylvain Le Gall";"2009-12-11 15:12";"";"2009-12-16 09:17";"Bad link for documentation";"Links to documentation are broken. See here: https://forge.ocamlcore.org/docman/?group_id=83# Then in ""API"": the link should be http://calendar.forge.ocamlcore.org/doc but the built URL is incorrect.";"forge.ocamlcore.org";"None" 618;1;"Open";3;102;"Sylvain Le Gall";100;"Nobody";"2010-05-05 08:19";"";"2010-05-05 08:19";"backup and postgresql";"We should backup data on the filesystem following this procedure: rsync -a pg-data pg-data-backup pg stop rsync -a pg-data pg-data-backup pg start This way we can do a consistent backup and minimize the downtime of pg.";"None";"None" 752;1;"Open";3;102;"Sylvain Le Gall";100;"Nobody";"2010-09-16 09:22";"";"2010-09-16 09:22";"Tests of dnsperfect.com returns some errors about ocamlcore.org domain";"Something about the SMTP server pointing to smtp.ocamlcore.com = smtp.ocamlcore.org";"None";"None" 796;1;"Open";3;294;"Philippe Veber";102;"Sylvain Le Gall";"2010-11-02 18:46";"";"2011-04-12 12:43";"No email notification after SVN commits";"Subversion commits are not followed by email notifications, though the corresponding mailing list is created by default (but remains empty). I do not know whether this is also the case for CVS projects.";"forge.ocamlcore.org";"None" 855;1;"Open";3;824;"Török Edwin";102;"Sylvain Le Gall";"2010-12-31 16:28";"";"2011-01-09 23:34";"long project names overlap tabs";"See https://forge.ocamlcore.org/frs/?group_id=175 ""ExtUnix - extended Unix module"" text overlaps with the Hudson tab";"forge.ocamlcore.org";"None" 857;1;"Open";3;103;"Stefano Zacchiroli";102;"Sylvain Le Gall";"2011-01-02 09:40";"";"2011-01-03 16:00";"default theme not refreshed after fusion forge upgrade";"After the upgrade to fusion forge, I've noticed *no* change to the default theme on forge.o.o Only now I've discovered that I see no changes only if I'm logged in, while if I'm not I do see the new brown-ish theme. In my preferences the chosen theme was ""Default Theme"" and I expected that choice to be automatically bumped to the new theme. Apparently this is not the case and, to see the new theme while logged in, I had to choose *explicitly* (which is unfortunate) ""OCaml Forge Official Theme"" from the list. Cheers.";"forge.ocamlcore.org";"None" 858;1;"Open";3;103;"Stefano Zacchiroli";102;"Sylvain Le Gall";"2011-01-02 09:42";"";"2011-01-20 14:07";"""Permission denied"" when following links from forge RSS feed";"Apparently, all links reported in the ""Latest news"" RSS feed lead to ""permission denied"" pages. As a random example from the last item in the feed, I get a ""permission denied"" error when following the following link: https://forge.ocamlcore.org/forum/forum.php?forum_id=762 Being logged in or not on the web interface seems to make no difference wahtsoever.";"forge.ocamlcore.org";"Yes" 867;1;"Open";3;824;"Török Edwin";102;"Sylvain Le Gall";"2011-01-08 09:19";"";"2012-01-14 18:08";"approving new project for user doesn't change unix_status";"Testcase: - register user - have user register new project - approve project User's unix status stays 'N', he can't see the SSH keys page, can't login. If admin clicks on 'update' on the useredit page, unix status changes to 'A'. Not sure if this helps, but in activateUsers(), Group->getUsers() /usr/share/gforge/common/include/Group.class.php returns an empty array for newly created group's members, so no users are activated for it.";"forge.ocamlcore.org";"Yes" 869;1;"Open";3;824;"Török Edwin";102;"Sylvain Le Gall";"2011-01-08 10:36";"";"2013-06-16 21:19";"Developer GIT url not shown";"Although I see a getInstructionsForRW() that is supposed to show the right info, it never appears on the page. I only see instructions for anonymous access, creating a private repo, browsing the repo, and downloading a snapshot.";"forge.ocamlcore.org";"Yes" 873;1;"Open";3;116;"ygrek ";102;"Sylvain Le Gall";"2011-01-13 13:37";"";"2011-01-20 14:13";"empty project unusable";"When creating new project start with ""empty project"". Add git scm -> no repo appears neither in interface nor git.ocamlcore.org listing. Add ""any logged in user"" role in admin->users and try to edit its permissions -> result: permission denied.";"forge.ocamlcore.org";"Yes" 882;1;"Open";3;827;"Xavier Clerc";102;"Sylvain Le Gall";"2011-01-19 05:29";"";"2011-01-20 14:14";"darcs repositoriy creation may provide the option to use ""darcs-2"" format";"Dear administrators, Currently the cookbook to use a ""darcs-2"" repository, as suggested by Sylvain, is the following: - ssh log to ""darcsroot/project/repo""; - either convert the old repository, or remove it and create a new one by ""darcs init --darcs-2. I have tested this on ""argot"", and it works perfectly - including the tool used to browse repositories online. However, I think that the option of creating a repository in the ""darcs-2"" format could be proposed (or even become the default, it a consensus emerges). Regards, Xavier Clerc";"forge.ocamlcore.org";"Yes" 884;1;"Open";3;834;"Ronan Le Hy";102;"Sylvain Le Gall";"2011-01-19 12:46";"";"2011-02-03 21:52";"auto-announce to OCaml Planet sends bad message";"As I was trying to make my wiki usable, I switched my project (caml-foreign) from Private to Public. This triggered an automated announce on OCaml Planet. I think this is very bad because people will arrive on a project with many many things, all empty (no code, wiki with no content, many links and buttons with nothing in it). This sends the message that : - this project is a dead project - OCaml Forge is a repository of dead empty projects, with misleading links and buttons promising a homepage and code and documentation and statistics, that actually have nothing behind. Each time I personnally click on such an announce for a yet-empty project, it makes me want to use github instead, were you know that project = code + README :(. I wish: - that the announce could be triggered only manually, or at the very least - that new projects were created with all tools disabled (such that the administrator enables things he knows lead to actual information), and that it were documented prominently during project registration that making a project public sends an automated announce.";"forge.ocamlcore.org";"None" 887;1;"Open";3;827;"Xavier Clerc";102;"Sylvain Le Gall";"2011-01-20 04:56";"";"2011-01-20 14:18";"Project creator not added to related Unix groups";"Dear administrators, When I tried to log through ssh in order to access to the repository of a project I created, I stumbled upon the problem that my login is not associated with the ""project"" and ""project_scm"" groups. The consequence is that I have not the needed privileges to write into the project source repository. For the record, the problem affects my login (""x9c"") in the ""bisect"", ""bolt"", ""kaputt"", and ""mascot"" projects. Curiously enough, the first project I registered (namely ""argot"") was correctly initialized. Regards, Xavier Clerc ";"forge.ocamlcore.org";"Yes" 904;1;"Open";3;834;"Ronan Le Hy";102;"Sylvain Le Gall";"2011-02-03 22:48";"";"2011-02-03 23:10";"wish: clarify some project tab names";"For clarity and simplicity, I wish some tabs were renamed: - Mediawiki -> Wiki - SCM -> Source code - Lists -> Mailing lists I think that most people do not care what kind of wiki they are reading. Also, I think that acronyms are better avoided (when possible), and that ""SCM"" is not explicit enough, especially since it is one of the most important tabs of all. Finally, I also find ""Lists"" not explicit enough. There are all sorts of lists on a typical forge project: lists of bugs, lists of documents, lists of events, lists of people...";"forge.ocamlcore.org";"Yes" 913;1;"Open";3;102;"Sylvain Le Gall";102;"Sylvain Le Gall";"2011-02-09 15:11";"";"2011-02-09 15:11";"Anon should have access to documentation read only by default";"We should switch anon in every project to have read only access to documentation manager.";"forge.ocamlcore.org";"None" 915;1;"Open";3;144;"Christophe Troestler";102;"Sylvain Le Gall";"2011-02-10 19:45";"";"2011-02-11 17:05";"hg repository: no web access";"On pages like https://forge.ocamlcore.org/scm/?group_id=43 the hg repository link is not correct — it should be ssh://hg.forge.ocamlcore.org//... — and there is no link to a“ web view” of the repository.";"forge.ocamlcore.org";"Yes" 931;1;"Open";3;233;"Julien Signoles";102;"Sylvain Le Gall";"2011-03-24 17:12";"";"2011-05-19 09:52";"Issues with Doc Manager";"Hello, I found various issues with the Doc Manager when I tried to update the file CHANGES of calendar. See https://forge.ocamlcore.org/docman/?group_id=83. 1) Button ""Edit this document"" doesn't seem to work 2) Button ""Remove"" seems to remove the file as expected since it does not appear anymore in the list BUT: a) the link still works : http://forge.ocamlcore.org/docman/view.php/83/51/CHANGES (I'm not sure that is really the same file actually ;-)) b) it is still not possible to upload a file called ""CHANGES"": there is an error ""Ce document a déjà été publié dans ce dossier"" (already published document). Thus after removing my old CHANGES, I found no way to add a new one :-(. -- Julien";"None";"Yes" 952;1;"Open";3;188;"Dawid Toton";102;"Sylvain Le Gall";"2011-04-10 19:23";"";"2011-06-20 09:42";"hg server crash";"hgweb dies: http://hg.ocamlcore.org/cgi-bin/hgwebdir.cgi/ocaml-installer/file (...) /usr/lib/pymodules/python2.5/mercurial/hgweb/webcommands.py (...) : local variable 'inst' referenced before assignment args = (""local variable 'inst' referenced before assignment"",) message = ""local variable 'inst' referenced before assignment"" ";"None";"None" 956;1;"Open";3;834;"Ronan Le Hy";102;"Sylvain Le Gall";"2011-04-19 20:14";"";"2011-05-19 13:59";"proposal: new CSS theme";"Hello, I have written a new CSS theme for the forge. I have explained what I have done in a blog post here: http://bayesien.posterous.com/ocaml-forge-theme-proposal The theme is here: http://rlehy.free.fr/forge-theme/theme.css (To be used it should replace themes/gforge/css/theme.css.) I hope you like it and could consider proposing it in place or in addition to the current theme. (No problem of course if you don't -- I know I am not an artist.)";"forge.ocamlcore.org";"None" 973;1;"Open";3;142;"Edgar Friendly";102;"Sylvain Le Gall";"2011-05-10 18:28";"";"2011-05-11 08:45";"Formatting failure when news items are posted to the planet";"I made a news post here: https://forge.ocamlcore.org/forum/forum.php?forum_id=793 which was turned into a planet post here http://planet.ocamlcore.org/ The news post does not allow any HTML formatting, so it was formatted as plain text. This plain text made its way through whatever channel it goes (RSS?) to the planet, upon which it was presented as HTML, whence it looks like poo. Is there any chance some markup converter can be applied to this text stream before it hits the planet? E.";"forge.ocamlcore.org";"Yes" 996;1;"Open";3;974;"Arthur MILCHIOR";100;"Nobody";"2011-06-17 09:08";"";"2011-06-17 09:08";"make of tuareg remove a directory";"I just downloaded tuareg 2.0.4 on https://forge.ocamlcore.org/frs/?group_id=43 I followed the README, using make install DEST=~/.emacs.d And it ended by doing an rm -rf /home/amilchior/.emacs.d Why are you deleting the folder ? that just makes no sens as far as I can tell. I wanted the file to be installed here, now the entire .emacs.d is deleted";"forge.ocamlcore.org";"None" 1037;1;"Open";3;890;"Jonathan Derque";100;"Nobody";"2011-09-21 15:57";"";"2011-09-21 15:57";"Developer URL for HG repositories is not working";"The url displayed in ""Developer Mercurial Access via SSH"" does not work correctly: $ hg -v clone ssh://jonathand@forge.ocamlcore.org/var/lib/gforge/chroot/scmrepos/hg/postgresql/ . running ssh jonathand@forge.ocamlcore.org ""hg -R var/lib/gforge/chroot/scmrepos/hg/postgresql/ serve --stdio"" remote: abort: There is no Mercurial repository here (.hg not found)! abort: no suitable response from remote hg! $ hg clone ssh://jonathand@forge.ocamlcore.org//var/lib/gforge/chroot/scmrepos/hg/postgresql/ . abort: destination '.' is not empty In order to fix the url you should: * double the slash after the ""forge.ocamlcore.org"" part * specify the project id as the destination directory instead of '.' In extenso: hg clone ssh://jonathand@forge.ocamlcore.org//var/lib/gforge/chroot/scmrepos/hg/postgresql/ postgresql";"None";"None" 1074;1;"Open";3;3986;"Didier Remy";100;"Nobody";"2012-01-02 10:34";"";"2012-01-02 10:34";"Account creation with existing login";"When attempted to create a new account with an existing login, the error message says that the ""user"" field is missing (and nothing else). It should instead ask the user to choose another ""login"" name. Moreover, - The form does not have a ""user"" field but a ""login"" field. The error message and the form should use the same naming convention. - The form is completely reset. The error message should prefilled the form with all other previously filled fields that need not be changed. Didier";"forge.ocamlcore.org";"None" 1124;1;"Open";3;437;"Florent Monnier";100;"Nobody";"2012-03-24 21:26";"";"2012-03-24 21:26";"the given URL does not work do get darcs sources anonymously";"On the sources pages, when darcs is used, the command given to get the sources anonymously doesn't work. For example on this page: http://forge.ocamlcore.org/scm/?group_id=68 the given command is: darcs get https://forge.ocamlcore.org/anonscm/darcs/optcomp/optcomp it doesn't work. => Solution: If I replace https by http it does work.";"None";"None" 1176;1;"Open";3;102;"Sylvain Le Gall";102;"Sylvain Le Gall";"2012-06-25 15:08";"";"2012-06-25 15:08";"Make sure that files dirname and tarball archive matches.";"In this URL http://forge.ocamlcore.org/frs/download.php/891/cryptokit-1.6.tar.gz What really says what will be downloaded is the number, not the archive name. Check that both matchs because ore return a 404.";"forge.ocamlcore.org";"None" 1208;1;"Open";3;7888;"Vladimir Brankov";100;"Nobody";"2012-09-02 19:10";"";"2012-09-02 21:18";"Access the repository using ssh";"Hello, I'm trying to access a repository using ssh. I'm working from my home laptop and I'm using Windows + cygwin, which I'm not very familiar with. I created a ssh rsa key and uploaded the public part on the server. However, ssh wouldn't work at all: ssh -vT vbrankov@forge.ocamlcore.org I waited a few hours after uploading my private key, as the instructions say. After a few attempts and different configurations I've been banned. Before I was getting: debug1: SSH2_MSG_SERVICE_ACCEPT received debug1: Authentications that can continue: publickey debug1: Next authentication method: publickey debug1: Trying private key: /home/Vlayceh/.ssh/id_rsa.pu debug1: No more authentication methods to try. Permission denied (publickey). Now it kicks me out at: debug1: Connection established. debug1: identity file /home/Vlayceh/.ssh/ZZZ type -1 debug1: identity file /home/Vlayceh/.ssh/ZZZ-cert type -1 ssh_exchange_identification: Connection closed by remote host Can you please help me access the repository. Thanks, Vladimir";"forge.ocamlcore.org";"None" 1214;1;"Open";3;7888;"Vladimir Brankov";100;"Nobody";"2012-09-04 14:32";"";"2012-09-05 12:40";"Site Admin doesn't see changes in the code";"Hello, I've set up a project ocaml-opencl with Mercurial repository on ssh://forge.ocamlcore.org/var/lib/gforge/chroot/scmrepos/hg/opencl-caml/. I pushed about 7-8 commits yesterday evening. However, Site Admin still doesn't see any files in the repository and doesn't report any activity. Can you help me with this? Thanks, Vladimir";"None";"None" 1260;1;"Open";3;10921;"Francois Pottier";100;"Nobody";"2013-02-26 10:28";"";"2013-02-26 10:28";"Tuareg mode does not properly highlight a multi-line error range";"When a type error message (reported by ocamlc) spans multiple lines, Tuareg mode highlights only the first line, instead of the entire range. This happens with Tuareg mode 2.0.6. An example is attached. The latest version of the Caml mode has two different error regexps (old style and new style) which Tuareg might wish to re-use? Thanks. ";"None";"None" 1354;1;"Open";3;144;"Christophe Troestler";100;"Nobody";"2013-11-30 14:14";"";"2013-11-30 17:48";"Wrongly transform HTML";"The feed http://roscidus.com/blog/blog/categories/ocaml/atom.xml has and
tags which are (wrongly) transformed to text in http://planet.ocaml.org/rss20.xml";"planet.ocamlcore.org";"None" 1453;1;"Open";3;17384;"Charles Hawkins";100;"Nobody";"2015-01-25 13:27";"";"2015-01-25 13:27";"Unable to allow anonymous posts to a forum";"I've set up my forum to allow anonymous posts, Moderated Level 1, but the system goes to a login screen if anyone tries to post. As admin, I went to the ""Users and permissions""/""Edit Permissions"" for Anonymous (and ""Any user logged in"") and changed the setting for the forum to ""Moderated Post"" but I get ""Permission Denied"" when I try to submit the change.";"forge.ocamlcore.org";"None" 1474;1;"Open";3;304;"Zog Zoggy";100;"Nobody";"2015-08-12 14:48";"";"2015-08-14 14:05";"Les statistiques ne fonctionnent pas";"Bonjour, La page permettant d'avoir des statistiques d'accès ne fonctionne pas, par exemple https://forge.ocamlcore.org/project/stats/?group_id=228 S'il est bien possible de spécifier des dates de début et fin et de choisir entre""Outil de suivi"" et ""Pages vues"", aucun graphe n'est affiché; à la place seulement un label ""stats graph"" . Ce qui m'intéresse en l'occurrence, ce sont les pages vues concernant mon support de formation ocaml. Bien cordialement, Maxence";"forge.ocamlcore.org";"None"